
Making GIS Work for You: How to Do Overlay 
Analysis to Create Depth Statistics

In this tutorial, we will learn how to create depth statistics for a chosen study area using 
QuantumGIS(QGIS). Examples of depth statistics include the average, maximum, and 
minimum depth of a 1° by 1°  grid ocean cell. 

The increase in the quality and quantity of aerial and satellite imagery opens the door for all 
kinds of impactful analysis. The combination of ever more dynamic, free geographic 
information systems (GIS) software and plentiful free data means  GIS is easily accessible to
individuals and small organizations. This tutorial will explore just one of the ways that GIS  
adds value to your data and facilitates powerful spatial analysis.

GIS Data Background
One use of remotely sensed data is the creation of digital elevation models (DEMs), which 
are used to model the elevation of the earth’s surface. If you clip these DEMs to the 
boundaries of an area of interest, you can determine elevation statistics for the area. You 
might want to know the average depth for a selection of Marine Protected Areas (MPAs), or 
you could be interested in which parts of the Mediterranean are deep enough to be habitable
by a certain marine species.

In GIS there are two main forms of data: raster and vector. As defined by ESRI, raster data 
represent the world “as a surface divided into a regular grid of cells”. Raster data are 
particularly useful for storing continuous data, such as satellite imagery and aerial 
photography. Vector data, meanwhile, represent features on the earth as points, lines, and 
polygons. Vectors are ideally suited to represent features such as streets, buildings, and 
national boundaries. 

In this tutorial, you will make use of both data types in order to calculate depth statistics 
(mean depth, minimum depth, maximum depth, etc)  for half-degree grid cells in your chosen
study area. What you are doing is known as an Overlay analysis, which is one of the most 
common forms of GIS analyses. The vector format you will use is known as a shapefile. 
Other formats are more stable and dynamic, but shapefiles are compatible with nearly all 
GIS programs, so they provide a good starting point for new GIS users. 

GIS Software
For the purpose of this analysis, you will use QGIS, which is a free, open source tool you 
can download and install on your computer from the following website:

https://www.qgis.org/en/site/forusers/download.html

https://www.qgis.org/en/site/forusers/download.html


Figure 1. Download QGIS

For those using an older computer, you might need to install the 32-bit version. Those  using
a newer machine, will likely  want to choose the link for the 64-bit download. Downloads are 
also available for Mac, Linux, BSD, and Android. 

Using the QGIS Installer makes installation simple. After following a few steps, QGIS will be 
ready to use. For users who experience problems during installation,  try running the QGIS 
Installer that is available at https://trac.osgeo.org/osgeo4w/

Download global terrain model
As mentioned in the introduction, you will use both raster and vector data for this analysis. In
order to calculate depth statistics for your study area, you will download a DEM known as a 
global terrain model (raster). Next, within QGIS, you will create a ½ degree polygon 
shapefile (vector). 

The global terrain model you will use for this analysis can be found here: 
http://www.gebco.net/data_and_products/gridded_bathymetry_data/

1. In order to select your study area, hold down the Shift button while pressing the left 
mouse button to create a rectangle around your area of interest. For the purposes of 
this tutorial, you willuse the Southern Atlantic Ocean adjacent to the western coast of 
Southern Africa. 

http://www.gebco.net/data_and_products/gridded_bathymetry_data/
https://trac.osgeo.org/osgeo4w/


Figure 2. How to select your study area.

Feel free to select a different region if you want. Just remember that the larger the 
area you select, the larger the file will be. Working with a large image file might lead 
to performance problems, depending on how powerful your machine is. 

2. Next, scroll down the page, and select GEBCO_2014 Grid (30 arc-second interval), 
and then check the box next to User-defined area, INT16 GeoTIFF (data). 



Figure 3. Choosing data type and adding data to your basket

3. Click  “Add to Basket”. 

4. Click  “View Basket”. 



5. After you click on the View Basket button, you will arrive at the following screen:

Figure 4. Checking out your GEBCO data

6. If everything looks okay, press the “Checkout your request” button. If you don’t have 
an account, you will be prompted to create one. Once you have created your 
account, you will be asked several questions about how you will use the data, and 
then given a download link. Save the data to a folder where you will be able to find it 
easily. 



Enable the QGIS Processing Toolbar
If you already have a polygon (vector) layer that you can use, creating the grid is 
unnecessary. Otherwise, follow the steps below.

1. Open QGIS

2. Use the following steps to add the Processing Toolbar to your project. The 
Processing toolbar allows you to search for tools within QGIS and other open source 
GIS software such as GRASS, GDAL, and Saga. 

a. Click on the Processing menu.

b. Select Toolbox.

3. The Processing Toolbar appears on the right side of your QGIS project, as shown 
below.

Figure 5. How to add the Processing Toolbar to your QGIS project.

4. Next, add the GEBCO imagery that you downloaded in the previous step. The
name of the file will tell you the coordinates of the file you downloaded, which will be 
useful in determining the limit of your grid

For example, in the file used for this tutorial, the bottom left hand corner of the imagery has 
an x,y value of -14.5, -40 and the upper right hand corner has an x.y value of 19, -10.9.

  



Create the half-degree grid shapefile
Now you will use the Grid tool to create the half-degree vector layer for your study area. In 
many cases, you might already have a polygon layer to use. For instance, if you wanted to 
know the average depth for Australian Marine Protected Areas (MPAs), and you already had
the MPA shapefile, the following steps wouldn’t be necessary. For the purposes of this 
tutorial, though, you need to create the grid before you can go any further. 

1. In the Processing Toolbar’s search box, type “grid”.

2. Under QGIS geoalgorithms, Vector creation tools, double click “Create grid”.

3. A Create grid dialog box opens. From the Grid type pull-down menu, select 
“Rectangle (polygon)”.

4. In Grid Extent, enter the minimum x value, maximum x value, minimum y value, and 
maximum y value. In this example,  use -14, 19, -40, -10. The grid should fit within 
the boundaries of the GEBCO imagery that you downloaded earlier.

5. Change the Horizontal spacing to 0.5.

6. Change the Vertical spacing to 0.5.

You want to use the CRS projection. Projections are a very important topic within GIS 
but can be confusing to new GIS users. In this case, you want the grid to have the 
same projection as the GEBCO imagery. 

7. Right click on the GEBCO imagery and select Properties. On the General tab of the 
Properties dialog box, you will see a Coordinate Reference System dropbox box. For 
GEBCO imagery, this is EPSG: 4326, WGS 84. This is the projection you want to use
for your grid also.

8. Save the file to a location of your choice and use a name that you will be able to 
easily recognize.

9. Click the Run button. The newly created layer is automatically added to your project. 
If the new lay is not added to the project, do the following:
a. On the Layer menu, click Add Layer → Add Raster Layer, or on your keyboard, 
simultaneously hold down Control + Shift + V.
b. In the Dataset field, click the Browse button, and then navigate to the location 
where you saved your file.
c. Select the file and then click Open



Figure 6. The steps to create a grid of half-degree cells

Use the Zonal Statistics tools to calculate depth values for each grid cell
It has taken a little bit of work to get to this point, but now creating depth statistics is quite 
simple.

1. In the Processing Toolbar’s search box, type “zonal”.

2. Under QGIS geoalgorithms, Raster tools, double click “Zonal statistics”. A Zonal 
statistics dialog box opens. In the Raster layer drop-down box, make sure that the 
GEBCO data you downloaded is listed.

3. In “Vector layer containing zones”, select the half-degree grid layer you just created.

4. Enter the the “Outcome column prefix”, which can be whatever you choose. For the 
purposes of this tutorial,   “grid_” was used as the prefix..

5. Click on the button next to the “Zonal statistics” field.

Save the file to a location of your choice and use a name that you will remember.

6. Click Run. 



Figure 7. The Zonal Statistics tool

Access and Edit the Zonal Statistics
QGIS creates a new grid shapefile (default name is “Zonal statistics”), whose attribute table 
includes depth statistics for each half-degree cell. 

You can open any vector layer’s attribute table by right clicking on the layer name in the 
Layer panel, and select Open Attribute Table from the resulting menu.

Figure 8. How to open a vector layer’s attribute table



The attribute table looks something like this:

Figure 9. The Attribute table for the Zonal statistics shapefile that you just created.

At this point, you are almost done. But what if you want to get rid of all those zeroes in 
Figure 9? You could export the attribute table and open the saved file in another program, 
such as Excel. Or you can use another tool in QGIS to create a version of the Zonal 
statistics shapefile with a cleaner looking attribute table.

Clean up the attribute table using MMQGIS
Unfortunately, QGIS doesn’t allow us to easily change the data format within an attribute 
table. However, there is an add-on that will allow us to get rid of all of those extra zeroes.

1. Click on the Plugins menu at the top of the screen, then select “Manage and Install 
Plugins”.

2. In the resulting Plugins dialog box, type “MMQGIS” in the search bar.

3. In the search results box, click once on “mmqgis”.

4. In the bottom right corner of the Plugins dialog box, click the “Install plugin” button.



Figure 10. Enable the MMQGIS plugin

5. A new MMQGIS menu appears at the top of the screen. Select the MMQGIS menu 
→ Modify → Float to Text.

Figure 11. Open the Float to Text tool



6. In the resulting Float to Text dialog box, under Source Layer, select “Zonal Statistics”.

Figure 12. Use the Float to Text to remove the extra zeroes.

7. In the Fields to Convert, while holding the Shift button, select all the fields except left,
top, right, and bottom. These are the coordinate fields, so you want to retain the 
decimal values for these four fields.

8. Under 000’s Separator, select Comma.

9. Under Decimal Places, select “0”.

10.  Under Output Shapefile, click the Browse button. Navigate to the file where you 
saved your other files, and then give the new shapefile a name you will recognize. In 
this example,  Study_area_depth_stats_Final.shp was used.

11. Click OK. 

12. A new shapefile is added to your project. If you open up the attribute table, the data 
should now look something like this (see next page):



Figure 12. This is what the attribute table looks like after removing the extra zeroes.

Exporting the Attribute Table
To do future analysis with this file within QGIS, you are now ready to go. If you only need the
tabular data, export this shapefile’s attribute table in a format such as CSV. To do so:

1. In the Layers Panel, right click on Study_area_depth_stats_Final.shp.

2. Click “Save As…”.

3. In the resulting dialog box, select Comma Separated Value (CSV) from the drop-
down box.

4. Under File name, click Browse and save the CSV to your desired file folder, and give 
it a name you will remember. In the example, I used the name 
“Depth_stats_table.csv”.

5. Click OK



Figure 13. Export the attribute table to CSV

Final Thoughts
The data created in this tutorial could be used for a variety of scientific analysis, including 
creating species distribution for marine mammals or developing a model that predicts the 
likelihood seagrass exists in a given area. 

Transferring the attributes of one layer to another is a useful way to add value to existing 
data. A layer showing ½ degree grid cells might not be valuable in and of itself. However, by 
adding depth values, you have created a layer that can be used for a variety of analyses, 
and really begins to tell a story about your study area.


